Micpad issues with Micress 6.4

Discussion of numerical issues which are not directly linked to specific applications
Post Reply
deepumaj1
Posts: 104
Joined: Fri Feb 13, 2015 11:00 am
anti_bot: 333
Contact:

Micpad issues with Micress 6.4

Post by deepumaj1 » Tue May 08, 2018 8:09 am

Hi.
I'm facing the following two issues with the new micress version (6.4), when I use Micpad.
1. When we stop the job in Micpad, it doesn't really stop and keeps running in the background.
2. If you restart a simulation with 'overwrite' option, crazy things happen. It tries to retain the old results and messes up everything.

These issues happen with Micress 6.4, with any Micpad version (even the 6.4 one). Has anything like this been reported already?

Deepu

ralph
Posts: 104
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Micpad issues with Micress 6.4

Post by ralph » Tue May 08, 2018 5:15 pm

Hi Deepu,

Did you give MICpad 6.402 a try ?
We fixed some issues, already (see Change_Log.txt), esp. regarding restarts.

The killing process prob is a new one. It's working like a charme on my side (Windows and Linux).
Are you sure that it was no old instance or detached in between? If you only open a driving file and did not start it from MICpad, you cannot kill the process.
Does a mouse over the tab title shows you a tooltip with the process id ?

Best,
Ralph

deepumaj1
Posts: 104
Joined: Fri Feb 13, 2015 11:00 am
anti_bot: 333
Contact:

Re: Micpad issues with Micress 6.4

Post by deepumaj1 » Tue May 08, 2018 6:45 pm

Hi Ralph,
I haven't tried MICpad 6.402 yet. I will give it a try.

Yes, it shows a wrong process id. For example, it showed me 45113 whereas the real one was 45114. (It always take one number less than the real process ID)

Deepu

ralph
Posts: 104
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Micpad issues with Micress 6.4

Post by ralph » Wed May 09, 2018 9:51 am

Which operating system do you use?

Ralph

deepumaj1
Posts: 104
Joined: Fri Feb 13, 2015 11:00 am
anti_bot: 333
Contact:

Re: Micpad issues with Micress 6.4

Post by deepumaj1 » Wed May 09, 2018 10:09 am

I'm facing this issue in Ubuntu 16.04 and Opensuse Leap 42.1. I haven't tested with Windows.

Deepu

ralph
Posts: 104
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Micpad issues with Micress 6.4

Post by ralph » Wed May 09, 2018 10:32 am

Ah, got it.
You use a starter script inside MICpad and this will be killed :)
If you start MICpad in an appropriate MICRESS environment and choose a MICRESS binary in the configuration, everything will work as expected.

Cheers,
Ralph

deepumaj1
Posts: 104
Joined: Fri Feb 13, 2015 11:00 am
anti_bot: 333
Contact:

Re: Micpad issues with Micress 6.4

Post by deepumaj1 » Wed May 09, 2018 10:36 am

Yes, it worked. Thanks Ralph.

Cheers,
Deepu

Post Reply