Stop in Routine outResult: Unable to open *_conc1.mcr

dendritic solidification, eutectics, peritectics,....
Post Reply
cboe
Posts: 13
Joined: Thu Feb 01, 2018 6:06 pm
anti_bot: 333

Stop in Routine outResult: Unable to open *_conc1.mcr

Post by cboe » Thu Jul 30, 2020 9:04 am

Hi,

I currently run a simulation with 200/1/16 000 cells (x/y/z) in order to calculate the directional solidification ranging from liquid to eutectic temperature. I want to know at which temperature cohesion between the solidifying dendrites occur and get an estimation for the fraction of solid as a function of the temperature gradient and cooling rate.

However, the following stop message occurs and I could not reach the eutectic temperature as desired:

Code: Select all

 Unable to open file OUTPUT/ALCU_TCG_P1_C2_conc1.mcr
 STOP in routine outResult
This error occured also for a smaller simulation with 200/1/10 000 cells (x/y/z)

I attached the input file. Did anyone face a similar issue already? Thank you for your help.

Kindly
Constantin
Attachments
ALCU_TCG_P1_C2.in
(17.32 KiB) Downloaded 98 times
---- Constantin

ralph
Posts: 115
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Stop in Routine outResult: Unable to open *_conc1.mcr

Post by ralph » Thu Jul 30, 2020 10:29 am

Hi Constantin,

you set a very short output interval.
Unfortunately, the compression library we use under Windows has a file size limit of 2 GB.
My test is still running but I guess this limit is reached esp. for concentration output because the compression rate for these files is lower than e.g. phase ids.

Change to vtk output ('overwrite vtk'). All fields of only one time step will be written to a file. This generates a series of files.

Best,
Ralph

cboe
Posts: 13
Joined: Thu Feb 01, 2018 6:06 pm
anti_bot: 333

Re: Stop in Routine outResult: Unable to open *_conc1.mcr

Post by cboe » Mon Aug 03, 2020 11:19 am

Hallo Ralph,

I used now the following command:

Code: Select all

 # Overwrite files with the same name?
 # Options:    overwrite      write_protected     append
 #             [zipped|not_zipped|vtk]
 #             [unix|windows|non_native] overwrite vtk
ascii
However, the simulation doesn't finish and I don't reach the final temperature at the bottom I aimed for. The error message is the following

Code: Select all

Error '5' while processing VTK output (status:                    38)
Each output file for a certain step is ~ 300 MB in size.

Thanks for your help.

Kind regards
Constantin
---- Constantin

ralph
Posts: 115
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Stop in Routine outResult: Unable to open *_conc1.mcr

Post by ralph » Mon Aug 03, 2020 5:49 pm

No idea what a Fortran IO error of 38 in this context means. Descriptions of this error state do not make sense for me in this context.

Anyway, ASCII presentation for real numbers (as in concentration fields) waste a lot of disk space. Have a look at the files with an normal text editor. Depending on the precision, it takes more than 10 bytes to store one value.

Choose a binary representation, i.e. 4 bytes for a single precision real number.

Code: Select all

# Overwrite files with the same name?
# Options:    overwrite      write_protected     append
#             [zipped|not_zipped|vtk]
#             [unix|windows|non_native]
overwrite vtk
# VTK output file format options?
# Options:  binary_unzip  binary_zip  ascii
binary_zip
I reproduced the simulation until step 26 and reached a single file size of 1700 KB. Should work.
DP_MICRESS is able to read this compressed VTK files. Paraview needs them uncompressed which can be done with a normal compression tool (Windows board utility or 7z for example).

Hope that helps.
Ralph

ralph
Posts: 115
Joined: Wed Apr 27, 2011 4:42 pm
anti_bot: 333

Re: Stop in Routine outResult: Unable to open *_conc1.mcr

Post by ralph » Tue Aug 04, 2020 9:27 am

DP_MICRESS might get stuck handling such a long file series. At least, I observed this on my computer.
You can copy a subset of the series to a subfolder to open it. Let's say about 20 files. This should work.

Best,
Ralph

Post Reply